Emprender o montar tu proyecto online es un camino lleno de decisiones. Quizá, una de las primeras a las que te has enfrentado ha sido elegir WordPress como CMS.

Bien, hasta aquí todo perfecto, pero como ya sabes, vas a necesitar un hosting para instalar tu WordPress. Más adelante veremos una guía básica sobre los puntos a tener en cuenta a la hora de elegir un buen hosting para tu proyecto. Pero hoy quiero hablarte de los requisitos para instalar WordPress que debes tener presentes en tu búsqueda de proveedor de hosting para tu proyecto. ¡Vamos con ello!

PHP7 o superior

PHP es un lenguaje de programación diseñado para el desarrollo web de sitios con contenido dinámico. Las siglas PHP significan PHP Hypertext Preprocessor (aunque inicialmente eran PHP Tools, o, Personal Home Page Tools).

Se encuentra instalado en más de 20 millones de sitios web y en un millón de servidores. Y parte de su popularidad proviene de que WordPress está programado en un alto porcentaje sobre código PHP.

PHP, al igual que WordPress y cualquier otro software, ha ido evolucionando con los años y ha ido teniendo diferentes versiones. En la actualidad, la última versión estable se encuentra en la 7.x. Por lo que cuando veas las características de tu futuro hosting, fíjate en que versión de PHP hay instalada en sus servidores.

Aunque WordPress puede trabajar sin problemas en versiones anteriores de PHP, como la versión 5.6, es recomendable manejar la última versión de PHP que tengas disponible.

Para que te hagas una idea, sería como conducir tu coche con el freno de mano puesto. En cada actualización de WordPress, los desarrolladores intentan explotar al máximo todas las posibilidades que la última versión de PHP les ofrece, por lo que si tienes una versión más antigua de PHP, puede que las nuevas funciones no se ejecuten correctamente cuando hagas una actualización de tu WordPress.

Por último, es recomendable tener siempre la última versión de PHP para evitar vulnerabilidades en tu WordPress por funciones o código que haya quedado comprometido por la desactualización del lenguaje PHP sobre el que está funcionando.

MYSQL 5.6 o superior

Para que WordPress funcione correctamente necesita PHP como lenguaje sobre el que ejecutarse en el servidor. Por otra parte, necesita un sitio donde almacenar los datos de nuestra web (usuarios, emails, contraseñas, posts, páginas, etc.). Para guardar todos estos datos es necesario que tu hosting tenga la opción de manejar bases de datos. MySQL no es más que un sistema de gestión de bases de datos. Por lo tanto, necesitas una base de datos para que tu proyecto en WordPress funcione, sí o sí.

El funcionamiento es simple. Cuando creas un contenido en tu WordPress, los datos se almacenan en varias tablas de una base de datos. Cuando alguien visita tu sitio web, se ejecuta el lenguaje PHP de la página que está visitando. Recoge los campos de información que necesita de la base de datos y el servidor monta una página HTML que entrega al usuario en su navegador. Este proceso dura milésimas de segundos y es imperceptible para el usuario. Pero al menos, básicamente, necesitas saber cómo funcionan las ‘tripas’ de tu proyecto online.

Al igual que PHP, en MySQL existen distintas versiones a medida que los desarrolladores las han ido actualizando. Por lo tanto, es recomendable utilizar la última versión disponible (5.6 o superior) para aprovechar todas las características y funcionalidades que MySQL le puede brindar a tu proyecto WordPress.

Mod_rewrite

Ya hemos visto que necesitas un lenguaje de programación y un sistema de gestión de bases de datos. En tercer lugar necesitas un requerimiento básico que tu proveedor de hosting debería proporcionarte. Se trata del módulo mod_rewrite. Veamos por qué.

La arquitectura de un servidor se compone de módulos. El servidor consta de una sección core o núcleo y distintos módulos que aportan funcionalidades diferentes. Dentro de todos estos módulos se encuentra mod_rewrite. Este módulo se encarga de la re-escritura de las URLs. Por lo tanto, es el que se encarga de convertir las URLs con parámetros y variables de WordPress en URLs ‘amigables’. Así, cualquier ser humano puede recordarlas o asociarlas fácilmente. Y lo que es mejor, que Google pueda asociar la URL de la página a su contenido. Y este punto, está directamente relacionado con el posicionamiento SEO de tu proyecto. Como ves, aunque no lo parezca a priori, todo está relacionado… ¡Así que atento a todos los detalles!

Certificado SSL

Aunque hasta septiembre de 2016 un certificado SSL era opcional para las webs (salvo que fuera un ecommerce o un organismo estatal), Google ha empezado a modificar su navegador Chrome para que empiece a mostrar avisos sobre la seguridad de las páginas web que visitas. Si has empezado a ver un candado rojo en la barra de direcciones de tu navegador, es por esto. La razón de esta decisión es buscar una mayor seguridad en Internet. Sobre todo en la transmisión de datos a través de la web.

Requisitos para instalar WordPress - Certificado SSL

¿Y qué es un certificado SSL? Pues un fichero informático generado por una entidad de certificación. Esta entidad asocia los datos de identidad del dominio a una persona, organismo o empresa, confirmando así su identidad digital en Internet.

Requisitos para instalar WordPress - Búsqueda HTTP

Este proceso, hasta abril de 2016, era de pago. Tú ‘comprabas’ el certificado SSL para tu dominio y la entidad de certificación validaba que ‘tudominio.com’ te pertenecía a ti, a tu empresa u organismo por un periodo de un año. Era de pago anual. De ahí que solamente aquellas webs que manejan datos sensibles lo tuvieran activo.

Let’s Encrypt

Pero en abril de 2016 nace el proyecto Let’s Encrypt, una entidad de certificación que emite certificados SSL gratuitos. Desarrollado por el Internet Security Research Group y respaldado por organismos como la Electronic Frontier Foundation (EFF), la Fundación Mozilla, OVH, Akamai, Cisco Systems, la Autoridad de Certificados IdenTrust, la Universidad de Michigan (U-M), la Stanford Law School y la Fundación Linux.

Este respaldo internacional hacen de Let’s Encrypt la mejor alternativa a los certificados SSL de pago y de ahí que Google, a través de Chrome, haya empezado a tomar medidas para forzar la instalación de un certificado SSL en todas las páginas web.

Por lo tanto, cuando empieces a mirar hosting para tu proyecto online, busca que tengan la opción de certificado SSL Let’s Encrypt. La mayoría de los principales proveedores de hosting ya lo tienen disponible en todos sus planes.

 

Así que toma tus decisiones. Hoy ya has dado otro paso más en el camino de tu proyecto online. Controlando estos cuatro requisitos (PHP, MySQL, Mod_rewrite y certificado SSL) estarás seguro de que tienes todo lo necesario. De este modo, la base sobre la que construir tu proyecto sea sólida, rápida y segura. ¡Manos a la obra! 😉

 

¿Quieres mejorar tu WordPress?

Accede a mi directorio de herramientas (actualmente tienes disponibles 1170 herramientas) y haz que tu proyecto suba de nivel de forma fácil y rápida.

Acceder

¿Olvidaste tu contraseña?